Package: golang-k8s-cli-runtime-dev (0.32.3-1)
Utility for building command-line tools for Kubernetes (library)
Other Packages Related to golang-k8s-cli-runtime-dev:
dep: [golang-github-google-gnostic-models-dev]
Protocol buffer models for gnostic
dep: [golang-github-google-go-cmp-dev]
Package for comparing Go values in tests
dep: [golang-github-google-uuid-dev]
generates and inspects UUIDs based on RFC 4122
dep: [golang-github-liggitt-tabwriter-dev]
Drop in replacement for golang text/tabwriter (library)
dep: [golang-github-moby-term-dev]
utilities for dealing with terminals
dep: [golang-github-spf13-cobra-dev]
Go library for creating powerful modern Go CLI applications
dep: [golang-github-spf13-pflag-dev]
Drop-in replacement for Go's flag package, implementing POSIX/GNU-style --flags
dep: [golang-github-stretchr-testify-dev]
sacred extension to the standard Go testing package
dep: [golang-golang-x-sync-dev]
Supplemental Go synchronization libraries
dep: [golang-golang-x-text-dev]
Supplementary Go text-related libraries
dep: [golang-github-evanphx-json-patch-dev]
Go library to apply RFC6902 patches and create and apply RFC7386 patches
dep: [golang-gopkg-yaml.v2-dev]
YAML support for the Go language
dep: [golang-k8s-api-dev] (>= 0.32)
Schema for Kubernetes server external API types (library)
dep: [golang-k8s-apimachinery-dev] (>= 0.32)
Shared typings for Kubernetes servers and clients (library)
dep: [golang-k8s-client-go-dev] (>= 0.32)
Go client for Kubernetes (library)
dep: [golang-k8s-klog-dev]
leveled execution logs for Go (library)
dep: [golang-k8s-kube-openapi-dev]
Kubernetes OpenAPI spec generation & serving (library)
dep: [golang-k8s-utils-dev]
Non-Kubernetes-specific utility libraries (library)
dep: [golang-k8s-sigs-kustomize-api-dev]
Core API components and utilities for Kustomize (library)
dep: [golang-k8s-sigs-kustomize-kyaml-dev]
Reading and writing Kubernetes Resource configuration as YAML (library)
dep: [golang-k8s-sigs-yaml-dev]
better way to marshal and unmarshal YAML in Golang (library)
Download golang-k8s-cli-runtime-dev
| Architecture | Package size | Installed size | Files | Package |
|---|---|---|---|---|
| all | 246 KiB | 7.3 MiB | list of files | Download |
Package file paths (0)
Paths come from the repository package-file index for the observed builds. They describe archive/package associations, not every file that will exist on a running system after maintainer scripts, alternatives, generated state, diversions, or installation choices.
No package-associated file paths were observed for the displayed build metadata.
Field source: Debian 13 (Trixie) main amd64
