Packages / openSUSE Tumbleweed / System/Libraries / libsmi

Package: libsmi (0.4.8-29.5)

A Library to Access SMI MIB Information

The purpose of libsmi is to * Give network management applications a concise programmer-friendly interface to access MIB module information * Separate the knowledge on SMI from the main parts of management applications * Allow addition of new kinds of MIB repositories without the need to adapt applications that make use of libsmi

Other Packages Related to libsmi:

  • dep: /usr/bin/sh

    Package not available

  • dep: libm.so.6()(64bit)

    Package not available

  • dep: libm.so.6(GLIBC_2.2.5)(64bit)

    Package not available

  • dep: libsmi.so.2()(64bit)

    Package not available

  • dep: libc.so.6(GLIBC_2.38)(64bit)

    Package not available

Download libsmi

ArchitecturePackage sizeInstalled sizeFilesPackage
x86_642.1 MiB16 MiBlist of filesDownload

Package file paths (388)

Showing the first 250 sorted package-associated paths. Use file search to locate a specific path.

  • /usr/bin/smicache
  • /usr/bin/smidiff
  • /usr/bin/smidump
  • /usr/bin/smilint
  • /usr/bin/smiquery
  • /usr/bin/smistrip
  • /usr/bin/smixlate
  • /usr/share/doc/packages/libsmi
  • /usr/share/doc/packages/libsmi/ANNOUNCE
  • /usr/share/doc/packages/libsmi/ChangeLog
  • /usr/share/doc/packages/libsmi/draft-irtf-nmrg-sming-02.txt
  • /usr/share/doc/packages/libsmi/draft-irtf-nmrg-smi-xml-00.txt
  • /usr/share/doc/packages/libsmi/draft-irtf-nmrg-smi-xml-01.txt
  • /usr/share/doc/packages/libsmi/ibrpib-assignments.txt
  • /usr/share/doc/packages/libsmi/README
  • /usr/share/doc/packages/libsmi/THANKS
  • /usr/share/doc/packages/libsmi/TODO
  • /usr/share/licenses/libsmi
  • /usr/share/licenses/libsmi/COPYING
  • /usr/share/man/man1/smicache.1.gz
  • /usr/share/man/man1/smidiff.1.gz
  • /usr/share/man/man1/smidump.1.gz
  • /usr/share/man/man1/smilint.1.gz
  • /usr/share/man/man1/smiquery.1.gz
  • /usr/share/man/man1/smistrip.1.gz
  • /usr/share/man/man1/smixlate.1.gz
  • /usr/share/man/man3/libsmi.3.gz
  • /usr/share/man/man3/smi_attribute.3.gz
  • /usr/share/man/man3/smi_class.3.gz
  • /usr/share/man/man3/smi_config.3.gz
  • /usr/share/man/man3/smi_event.3.gz
  • /usr/share/man/man3/smi_identity.3.gz
  • /usr/share/man/man3/smi_macro.3.gz
  • /usr/share/man/man3/smi_module.3.gz
  • /usr/share/man/man3/smi_node.3.gz
  • /usr/share/man/man3/smi_render.3.gz
  • /usr/share/man/man3/smi_type.3.gz
  • /usr/share/man/man3/smi_util.3.gz
  • /usr/share/mibs
  • /usr/share/mibs/iana
  • /usr/share/mibs/iana/IANA-ADDRESS-FAMILY-NUMBERS-MIB
  • /usr/share/mibs/iana/IANA-CHARSET-MIB
  • /usr/share/mibs/iana/IANA-FINISHER-MIB
  • /usr/share/mibs/iana/IANA-GMPLS-TC-MIB
  • /usr/share/mibs/iana/IANAifType-MIB
  • /usr/share/mibs/iana/IANA-IPPM-METRICS-REGISTRY-MIB
  • /usr/share/mibs/iana/IANA-ITU-ALARM-TC-MIB
  • /usr/share/mibs/iana/IANA-LANGUAGE-MIB
  • /usr/share/mibs/iana/IANA-MALLOC-MIB
  • /usr/share/mibs/iana/IANA-MAU-MIB
  • /usr/share/mibs/iana/IANA-PRINTER-MIB
  • /usr/share/mibs/iana/IANA-RTPROTO-MIB
  • /usr/share/mibs/iana/IANATn3270eTC-MIB
  • /usr/share/mibs/ietf
  • /usr/share/mibs/ietf/ACCOUNTING-CONTROL-MIB
  • /usr/share/mibs/ietf/ADSL2-LINE-MIB
  • /usr/share/mibs/ietf/ADSL2-LINE-TC-MIB
  • /usr/share/mibs/ietf/ADSL-LINE-EXT-MIB
  • /usr/share/mibs/ietf/ADSL-LINE-MIB
  • /usr/share/mibs/ietf/ADSL-TC-MIB
  • /usr/share/mibs/ietf/AGENTX-MIB
  • /usr/share/mibs/ietf/AGGREGATE-MIB
  • /usr/share/mibs/ietf/ALARM-MIB
  • /usr/share/mibs/ietf/APM-MIB
  • /usr/share/mibs/ietf/APPC-MIB
  • /usr/share/mibs/ietf/APPLETALK-MIB
  • /usr/share/mibs/ietf/APPLICATION-MIB
  • /usr/share/mibs/ietf/APPN-DLUR-MIB
  • /usr/share/mibs/ietf/APPN-MIB
  • /usr/share/mibs/ietf/APPN-TRAP-MIB
  • /usr/share/mibs/ietf/APS-MIB
  • /usr/share/mibs/ietf/ARC-MIB
  • /usr/share/mibs/ietf/ATM2-MIB
  • /usr/share/mibs/ietf/ATM-ACCOUNTING-INFORMATION-MIB
  • /usr/share/mibs/ietf/ATM-MIB
  • /usr/share/mibs/ietf/ATM-TC-MIB
  • /usr/share/mibs/ietf/BGP4-MIB
  • /usr/share/mibs/ietf/BLDG-HVAC-MIB
  • /usr/share/mibs/ietf/BRIDGE-MIB
  • /usr/share/mibs/ietf/CHARACTER-MIB
  • /usr/share/mibs/ietf/CIRCUIT-IF-MIB
  • /usr/share/mibs/ietf/CLNS-MIB
  • /usr/share/mibs/ietf/COFFEE-POT-MIB
  • /usr/share/mibs/ietf/COPS-CLIENT-MIB
  • /usr/share/mibs/ietf/DECNET-PHIV-MIB
  • /usr/share/mibs/ietf/DIAL-CONTROL-MIB
  • /usr/share/mibs/ietf/DIFFSERV-CONFIG-MIB
  • /usr/share/mibs/ietf/DIFFSERV-DSCP-TC
  • /usr/share/mibs/ietf/DIFFSERV-MIB
  • /usr/share/mibs/ietf/DIRECTORY-SERVER-MIB
  • /usr/share/mibs/ietf/DISMAN-EVENT-MIB
  • /usr/share/mibs/ietf/DISMAN-EXPRESSION-MIB
  • /usr/share/mibs/ietf/DISMAN-NSLOOKUP-MIB
  • /usr/share/mibs/ietf/DISMAN-PING-MIB
  • /usr/share/mibs/ietf/DISMAN-SCHEDULE-MIB
  • /usr/share/mibs/ietf/DISMAN-SCRIPT-MIB
  • /usr/share/mibs/ietf/DISMAN-TRACEROUTE-MIB
  • /usr/share/mibs/ietf/DLSW-MIB
  • /usr/share/mibs/ietf/DNS-RESOLVER-MIB
  • /usr/share/mibs/ietf/DNS-SERVER-MIB
  • /usr/share/mibs/ietf/DOCS-BPI-MIB
  • /usr/share/mibs/ietf/DOCS-CABLE-DEVICE-MIB
  • /usr/share/mibs/ietf/DOCS-IETF-BPI2-MIB
  • /usr/share/mibs/ietf/DOCS-IETF-CABLE-DEVICE-NOTIFICATION-MIB
  • /usr/share/mibs/ietf/DOCS-IETF-QOS-MIB
  • /usr/share/mibs/ietf/DOCS-IETF-SUBMGT-MIB
  • /usr/share/mibs/ietf/DOCS-IF-MIB
  • /usr/share/mibs/ietf/DOT12-IF-MIB
  • /usr/share/mibs/ietf/DOT12-RPTR-MIB
  • /usr/share/mibs/ietf/DOT3-EPON-MIB
  • /usr/share/mibs/ietf/DOT3-OAM-MIB
  • /usr/share/mibs/ietf/DS0BUNDLE-MIB
  • /usr/share/mibs/ietf/DS0-MIB
  • /usr/share/mibs/ietf/DS1-MIB
  • /usr/share/mibs/ietf/DS3-MIB
  • /usr/share/mibs/ietf/DSA-MIB
  • /usr/share/mibs/ietf/DSMON-MIB
  • /usr/share/mibs/ietf/EBN-MIB
  • /usr/share/mibs/ietf/EFM-CU-MIB
  • /usr/share/mibs/ietf/ENTITY-MIB
  • /usr/share/mibs/ietf/ENTITY-SENSOR-MIB
  • /usr/share/mibs/ietf/ENTITY-STATE-MIB
  • /usr/share/mibs/ietf/ENTITY-STATE-TC-MIB
  • /usr/share/mibs/ietf/ETHER-CHIPSET-MIB
  • /usr/share/mibs/ietf/EtherLike-MIB
  • /usr/share/mibs/ietf/ETHER-WIS
  • /usr/share/mibs/ietf/FCIP-MGMT-MIB
  • /usr/share/mibs/ietf/FC-MGMT-MIB
  • /usr/share/mibs/ietf/FDDI-SMT73-MIB
  • /usr/share/mibs/ietf/FIBRE-CHANNEL-FE-MIB
  • /usr/share/mibs/ietf/Finisher-MIB
  • /usr/share/mibs/ietf/FLOW-METER-MIB
  • /usr/share/mibs/ietf/FRAME-RELAY-DTE-MIB
  • /usr/share/mibs/ietf/FR-ATM-PVC-SERVICE-IWF-MIB
  • /usr/share/mibs/ietf/FR-MFR-MIB
  • /usr/share/mibs/ietf/FRNETSERV-MIB
  • /usr/share/mibs/ietf/FRSLD-MIB
  • /usr/share/mibs/ietf/GMPLS-LABEL-STD-MIB
  • /usr/share/mibs/ietf/GMPLS-LSR-STD-MIB
  • /usr/share/mibs/ietf/GMPLS-TC-STD-MIB
  • /usr/share/mibs/ietf/GMPLS-TE-STD-MIB
  • /usr/share/mibs/ietf/GSMP-MIB
  • /usr/share/mibs/ietf/HC-ALARM-MIB
  • /usr/share/mibs/ietf/HCNUM-TC
  • /usr/share/mibs/ietf/HC-PerfHist-TC-MIB
  • /usr/share/mibs/ietf/HC-RMON-MIB
  • /usr/share/mibs/ietf/HDSL2-SHDSL-LINE-MIB
  • /usr/share/mibs/ietf/HOST-RESOURCES-MIB
  • /usr/share/mibs/ietf/HOST-RESOURCES-TYPES
  • /usr/share/mibs/ietf/HPR-IP-MIB
  • /usr/share/mibs/ietf/HPR-MIB
  • /usr/share/mibs/ietf/IANA-ITU-ALARM-TC-MIB
  • /usr/share/mibs/ietf/IF-CAP-STACK-MIB
  • /usr/share/mibs/ietf/IFCP-MGMT-MIB
  • /usr/share/mibs/ietf/IF-INVERTED-STACK-MIB
  • /usr/share/mibs/ietf/IF-MIB
  • /usr/share/mibs/ietf/IGMP-STD-MIB
  • /usr/share/mibs/ietf/INET-ADDRESS-MIB
  • /usr/share/mibs/ietf/INTEGRATED-SERVICES-GUARANTEED-MIB
  • /usr/share/mibs/ietf/INTEGRATED-SERVICES-MIB
  • /usr/share/mibs/ietf/INTERFACETOPN-MIB
  • /usr/share/mibs/ietf/IPATM-IPMC-MIB
  • /usr/share/mibs/ietf/IP-FORWARD-MIB
  • /usr/share/mibs/ietf/IPMCAST-MIB
  • /usr/share/mibs/ietf/IP-MIB
  • /usr/share/mibs/ietf/IPMROUTE-STD-MIB
  • /usr/share/mibs/ietf/IPOA-MIB
  • /usr/share/mibs/ietf/IPS-AUTH-MIB
  • /usr/share/mibs/ietf/IPSEC-SPD-MIB
  • /usr/share/mibs/ietf/IPV6-FLOW-LABEL-MIB
  • /usr/share/mibs/ietf/IPV6-ICMP-MIB
  • /usr/share/mibs/ietf/IPV6-MIB
  • /usr/share/mibs/ietf/IPV6-MLD-MIB
  • /usr/share/mibs/ietf/IPV6-TC
  • /usr/share/mibs/ietf/IPV6-TCP-MIB
  • /usr/share/mibs/ietf/IPV6-UDP-MIB
  • /usr/share/mibs/ietf/ISCSI-MIB
  • /usr/share/mibs/ietf/ISDN-MIB
  • /usr/share/mibs/ietf/ISIS-MIB
  • /usr/share/mibs/ietf/ISNS-MIB
  • /usr/share/mibs/ietf/ITU-ALARM-MIB
  • /usr/share/mibs/ietf/ITU-ALARM-TC-MIB
  • /usr/share/mibs/ietf/Job-Monitoring-MIB
  • /usr/share/mibs/ietf/L2TP-MIB
  • /usr/share/mibs/ietf/LANGTAG-TC-MIB
  • /usr/share/mibs/ietf/LMP-MIB
  • /usr/share/mibs/ietf/MALLOC-MIB
  • /usr/share/mibs/ietf/MAU-MIB
  • /usr/share/mibs/ietf/MIDCOM-MIB
  • /usr/share/mibs/ietf/MIOX25-MIB
  • /usr/share/mibs/ietf/MIP-MIB
  • /usr/share/mibs/ietf/MOBILEIPV6-MIB
  • /usr/share/mibs/ietf/Modem-MIB
  • /usr/share/mibs/ietf/MPLS-FTN-STD-MIB
  • /usr/share/mibs/ietf/MPLS-L3VPN-STD-MIB
  • /usr/share/mibs/ietf/MPLS-LC-ATM-STD-MIB
  • /usr/share/mibs/ietf/MPLS-LC-FR-STD-MIB
  • /usr/share/mibs/ietf/MPLS-LDP-ATM-STD-MIB
  • /usr/share/mibs/ietf/MPLS-LDP-FRAME-RELAY-STD-MIB
  • /usr/share/mibs/ietf/MPLS-LDP-GENERIC-STD-MIB
  • /usr/share/mibs/ietf/MPLS-LDP-STD-MIB
  • /usr/share/mibs/ietf/MPLS-LSR-STD-MIB
  • /usr/share/mibs/ietf/MPLS-TC-STD-MIB
  • /usr/share/mibs/ietf/MPLS-TE-STD-MIB
  • /usr/share/mibs/ietf/MSDP-MIB
  • /usr/share/mibs/ietf/MTA-MIB
  • /usr/share/mibs/ietf/NAT-MIB
  • /usr/share/mibs/ietf/NETWORK-SERVICES-MIB
  • /usr/share/mibs/ietf/NHRP-MIB
  • /usr/share/mibs/ietf/NOTIFICATION-LOG-MIB
  • /usr/share/mibs/ietf/OPT-IF-MIB
  • /usr/share/mibs/ietf/OSPF-MIB
  • /usr/share/mibs/ietf/OSPF-TRAP-MIB
  • /usr/share/mibs/ietf/PARALLEL-MIB
  • /usr/share/mibs/ietf/P-BRIDGE-MIB
  • /usr/share/mibs/ietf/PerfHist-TC-MIB
  • /usr/share/mibs/ietf/PIM-MIB
  • /usr/share/mibs/ietf/PIM-STD-MIB
  • /usr/share/mibs/ietf/PINT-MIB
  • /usr/share/mibs/ietf/PKTC-IETF-MTA-MIB
  • /usr/share/mibs/ietf/PKTC-IETF-SIG-MIB
  • /usr/share/mibs/ietf/POLICY-BASED-MANAGEMENT-MIB
  • /usr/share/mibs/ietf/POWER-ETHERNET-MIB
  • /usr/share/mibs/ietf/PPP-BRIDGE-NCP-MIB
  • /usr/share/mibs/ietf/PPP-IP-NCP-MIB
  • /usr/share/mibs/ietf/PPP-LCP-MIB
  • /usr/share/mibs/ietf/PPP-SEC-MIB
  • /usr/share/mibs/ietf/Printer-MIB
  • /usr/share/mibs/ietf/PTOPO-MIB
  • /usr/share/mibs/ietf/Q-BRIDGE-MIB
  • /usr/share/mibs/ietf/RADIUS-ACC-CLIENT-MIB
  • /usr/share/mibs/ietf/RADIUS-ACC-SERVER-MIB
  • /usr/share/mibs/ietf/RADIUS-AUTH-CLIENT-MIB
  • /usr/share/mibs/ietf/RADIUS-AUTH-SERVER-MIB
  • /usr/share/mibs/ietf/RADIUS-DYNAUTH-CLIENT-MIB
  • /usr/share/mibs/ietf/RADIUS-DYNAUTH-SERVER-MIB
  • /usr/share/mibs/ietf/RAQMON-MIB
  • /usr/share/mibs/ietf/RDBMS-MIB
  • /usr/share/mibs/ietf/RFC1065-SMI
  • /usr/share/mibs/ietf/RFC1155-SMI
  • /usr/share/mibs/ietf/RFC1158-MIB
  • /usr/share/mibs/ietf/RFC-1212
  • /usr/share/mibs/ietf/RFC1213-MIB
  • /usr/share/mibs/ietf/RFC-1215
  • /usr/share/mibs/ietf/RFC1269-MIB
  • /usr/share/mibs/ietf/RFC1271-MIB
  • /usr/share/mibs/ietf/RFC1285-MIB
  • /usr/share/mibs/ietf/RFC1316-MIB
  • /usr/share/mibs/ietf/RFC1381-MIB
  • /usr/share/mibs/ietf/RFC1382-MIB

Field source: openSUSE Tumbleweed OSS

Use this package

OpenFactory can boot this operating system in a browser VM, or start a build that includes the native package name from this record.

Versions, suites, and repositories

Each row is recorded package-index metadata for one version, architecture, suite, and repository. Names, URLs, and sizes are source-reported; a link is a potentially mutable retrieval location, not an OpenFactory redistribution claim or proof that OpenFactory retained the artifact bytes.

VersionReleaseArchitectureRepositoryPackage sizeInstalled sizePublisher repository artifact
0.4.8-29.5tumbleweed / ossx86_64openSUSE Tumbleweed · OSS · multi-architecture2.1 MiB16 MiBx86_64/libsmi-0.4.8-29.5.x86_64.rpm

Field source: openSUSE Tumbleweed OSS

Known vulnerabilities

Matching against OpenFactory catalog package versions is in progress.

Fixed and unaffected versions (1)
CVESeverityVersion impact
[CVE-2010-2891]

Published:

libsmi: CVE-2010-2891

MediumFixed
Details (1)
  • 0.4.8-29.5 · x86_64 · tumbleweed

    Fixed · Fixed: 0.4.8-24.8

    dsa · libsmi · opensuse · tumbleweed

Last synced:

[CVE catalog]

Checksums

Repository signatures authenticate metadata. Artifact hashing is recorded separately. Neither establishes package safety.

0.4.8-29.5 / x86_64Observed Sep 1, 2026sha512 a9dddf36fd10…75fd8d9cSource-reported digest

Metadata observed; artifact bytes were not independently fetched or hashed by this catalog import. The digest below is source-reported.

Source-reported digest (sha512): a9dddf36fd107cf1773a7ac49d62ff929b8cd015a7244743ec3eded06811d470e57d90c22c0c846617c284a019f8281192aabd3c1eb335dbd635a8e575fd8d9c

Field source: openSUSE Tumbleweed OSS

Sources

  • Authoritative source; repository metadata signature verified

    Signature evidence

    tumbleweed-oss-multiarch:4db10cdde3ad82c7e22be35753c9e164b4bdd30f92db4aee17a0d4c94c5f902f

    Repository-signature verification record
    Signed-object SHA-256
    4db10cdde3ad82c7e22be35753c9e164b4bdd30f92db4aee17a0d4c94c5f902f
    Signer fingerprint
    AD485664E901B867051AB15F35A2F86E29B700A4
    Keyring revision
    opensuse-project-signing-key.asc
    SHA-256 b5745739ebfb95b25b8e810f9bcb847fe750ccda598bd85f02f0e974599a6d7e
    Tool and policy
    gpgv (GnuPG) 2.4.9
    openfactory-software-catalog-signature-v1
    Verification time
    Sep 1, 2026
    Repository metadata hash linkage
    Result
    Recorded as verified; digest details unavailable